• Welcome to the Speedsolving.com, home of the web's largest puzzle community!
    You are currently viewing our forum as a guest which gives you limited access to join discussions and access our other features.

    Registration is fast, simple and absolutely free so please, join our community of 40,000+ people from around the world today!

    If you are already a member, simply login to hide this message and begin participating in the community!

what is your valk elite setup

  • Thread starter Deleted member 54663
  • Start date
D

Deleted member 54663

Guest
Mine is gravitas on tracks, weight 3 on pieces, and then some gan magic lube(idk)

A smooth fast feel

Weird because of the gan lubd
 

SpeedyCube

Member
Joined
Aug 21, 2020
Messages
104
Location
Planet Earth... I think...
I just got a Valk 3 Elite M. I HATE the feel of it. I know part of it is just that it takes time to be “broken in,” but it just doesn’t feel right, even if I change the settings. (I currently have the red springs with the clear magnets, which I so far like the best.)

I have some Gan lube. I’m thinking of putting a drop or two on. Question: would that have negative effects, considering it came lubed with something (standard QiYi lube?) already?

Also, does the corner cutting seem to be a bit lacking to anyone else?
 

Sion

Member
Joined
Dec 13, 2015
Messages
987
Location
New York
I personally have mine set up on Red springs and Clear magnets, moderate tensions. It is currently my main
 

SpeedyCube

Member
Joined
Aug 21, 2020
Messages
104
Location
Planet Earth... I think...
Sorry, I should have clarified my earlier post. What I meant by hate the feel is that it doesn’t turn smoothly. I changed out the red springs for green, with clear magnets, and i like that a little better. But... it still doesn’t seem like it’s a smooth cube. Should I add some Gan lube, or not really?

Also, is there anything I can do to improve the corner cutting? It seems really poor to me. Would loosening the spring screws improve that, or not so much?
 
D

Deleted member 54663

Guest
I just got a Valk 3 Elite M. I HATE the feel of it. I know part of it is just that it takes time to be “broken in,” but it just doesn’t feel right, even if I change the settings. (I currently have the red springs with the clear magnets, which I so far like the best.)

I have some Gan lube. I’m thinking of putting a drop or two on. Question: would that have negative effects, considering it came lubed with something (standard QiYi lube?) already?

Also, does the corner cutting seem to be a bit lacking to anyone else?
Some time later, I did something that TOTALLY changed the feel. I have clear magnets and clear springs, but put weight 6 into the plastic-encased springs. This made it sooo smooth, and then put gravitas on the tracks, and some weight 3. This is much better than the last setup, i love it. And no do not add gan lube, it makes it less smooth, even though in general the lube works very well on other Qiyi cubes, like the MS or the Xman volt. I also find the green springs to work well, but the cube got too flexible at one point.
 

SpeedyCube

Member
Joined
Aug 21, 2020
Messages
104
Location
Planet Earth... I think...
Some time later, I did something that TOTALLY changed the feel. I have clear magnets and clear springs, but put weight 6 into the plastic-encased springs. This made it sooo smooth, and then put gravitas on the tracks, and some weight 3. This is much better than the last setup, i love it. And no do not add gan lube, it makes it less smooth, even though in general the lube works very well on other Qiyi cubes, like the MS or the Xman volt. I also find the green springs to work well, but the cube got too flexible at one point.

Thanks for the reply! I’m not familiar with weight 6 or weight 3. Is that something I can buy? Is it a lube for springs?

Thanks for putting up with my dumb questions.
 

Gnome

Member
Joined
Aug 24, 2020
Messages
79
Location
Gwlad y Dreigiau
YouTube
Visit Channel
I currently have (after 50~ solves) green springs and clear magnets in mine, 50k weight Traxxas inside and nothing on the springs (yet).

I'm planning to break it in over the next few days (1-2 Ao100's) so I'll probably respond again after that but for now the cube reminds me very much of the old days where cubes were snappy, sharp and responsive; owing to their internally square nature. As opposed to round, soft and clicky like how I personally describe almost all modern "designed for maximum corner cutting at the expense of stability" cubes.

This is all to sayi like the cube.. I like square and snappy, it's how a cube should feel.
 
D

Deleted member 54663

Guest
Thanks for the reply! I’m not familiar with weight 6 or weight 3. Is that something I can buy? Is it a lube for springs?

Thanks for putting up with my dumb questions.
Weight 3 and 6 are silicone lubes, weight 6 being heavy, and good for the springs. It is available at most cube stores, and for sure at the cubicle and speedcubeshop. I recommend using something else, like max command or a premium lube from the cubicle, but weight 5/6 works well(the only one I have). If you have any non-water based heavy lubes, put it inside the spring in the Valk elite, and it will be very good. I put weight 3 in the cube since it is controllable yet does not slow down the cube, unlike weight 5/6.
 

SpeedyCube

Member
Joined
Aug 21, 2020
Messages
104
Location
Planet Earth... I think...
Well, some good if embarrassing news. Ever since opening the box I’ve felt like I’ve been fighting the cube when turning it. When I changed the springs I tried to screw in the screws as much as they were originally.

Last night a thought struck me, and I loosened the screws about a full turn each. MAN what a difference! It feels like it’s a pretty decent cube now! And... corner cutting isn’t so terrible any more. I think I’ll hold off on outside modifications for a bit and try out the cube as is, now that it’s working properly.

Baaaahhh... sheepish grin.
 
Joined
Aug 25, 2020
Messages
22
I have the red center magnets in mine and I believe that I put DNM-37 and Lubicle Speedy in mine. My problem with it is that it corner twists way too easily.
 
D

Deleted member 54663

Guest
I have the red center magnets in mine and I believe that I put DNM-37 and Lubicle Speedy in mine. My problem with it is that it corner twists way too easily.
The corner twists are not present on mine, probably because of the tighter settings. My setting is before on this thread, very good.

Just done this with another cube I own and DAMN .. it's suddenly not creaking every time i turn a face .. time to break out the Valk and go again!
This doesn't just help with spring noise, it also helps with smoothness and control.
 
D

Deleted member 54663

Guest
For now the thing I'm noticing the most is the lack of spring noise.. there is none, it's amazing!

I plan on doing an average or two later / this evening so I'll likely notice the stability upgrade then.. although it's definitely already smoother on slice turns now.
I used to use Green magnets, where IMO slice turns are very smooth, since the center magnet system is not good for slices(cfop cube).
 

Gnome

Member
Joined
Aug 24, 2020
Messages
79
Location
Gwlad y Dreigiau
YouTube
Visit Channel
I used to use Green magnets, where IMO slice turns are very smooth, since the center magnet system is not good for slices(cfop cube).

Ohhhhh my .. that is smoooooth .. I think this cube may have just entered "main" teritory :cool:

EDIT: Jup, this is a main.. half a second off my Ao5 PB with the first 5 solves (no warm up)

Ao5: 18.653

1. (16.572)
2. 18.643
3. 19.375
4. (20.029)
5. 17.940

EDIT: Yes, I really really really really really like this now

Ao5: 17.217

1. 18.689
2. 16.516
3. (16.378)
4. 16.445
5. (18.832)

Part of my first sub 20 Ao50 also: 19.732
 
Last edited:

SpeedyCube

Member
Joined
Aug 21, 2020
Messages
104
Location
Planet Earth... I think...
As a follow up, I’ve been experimenting with the different settings. Right now I’m loving the green-on-green feel. Also, it seems whatever lubricant came in it has now fully spread to the rest of the cube, as it’s turning much smoother now.
 
D

Deleted member 54663

Guest
As a follow up, I’ve been experimenting with the different settings. Right now I’m loving the green-on-green feel. Also, it seems whatever lubricant came in it has now fully spread to the rest of the cube, as it’s turning much smoother now.
I used to use green with green, but it was too unstable(even with slow lubes), so I recommend clear with clear, or clear with green magnets. I switch between the 2, but clear magnets give me more stability. When I'm turning slowly, the clear magnets feel way too strong, but are perfect during a solve. In terms of feel, the green is my favorite.
 
D

Deleted member 54663

Guest
lol i actually went outside and fell asleep on a hamoc, when i woke up it was raining
idk, i sleep indoors. jkjk if its raining use the case that came with the valk elite, very good. I didn't keep on using it though becuase it was hard to open and close and put a scratch on the cube.
 

SpeedyCube

Member
Joined
Aug 21, 2020
Messages
104
Location
Planet Earth... I think...
Not that this specifically applies to the Valk Elite, but I try to keep all my cubes in their respective cases when not using them. Yes, it’s annoying to constantly open / close, but there’s a reason. Cases keep off the dust and dirt, which when mixed with oil, tends to become gunky.

“An once of prevention....”
 

SpeedyCube

Member
Joined
Aug 21, 2020
Messages
104
Location
Planet Earth... I think...
I don’t know. I keep going back and forth between green spring with green or clear magnets. I really like the feel of the green on green, but they just don’t stop it quite enough when I’m solving. I guess the feel just takes a little getting used to... I broke my PB of 37.096 with 37.091. Of course that was after my average went up by 10 seconds or so for a while....
 
Top