• Welcome to the Speedsolving.com, home of the web's largest puzzle community!
    You are currently viewing our forum as a guest which gives you limited access to join discussions and access our other features.

    Registration is fast, simple and absolutely free so please, join our community of 30,000+ people from around the world today!

    If you are already a member, simply login to hide this message and begin participating in the community!

Report Issues Here

pjk

Administrator
Staff member
Joined
Mar 13, 2006
Messages
6,087
Likes
328
WCA
2007KELL02
YouTube
pjkcards
Thread starter #1
Please report any bugs, issues, forum suggestions, concerns, etc. in this thread here. Often times if an issue isn't reported, we don't know it exists. We rely on the community to report bugs and make suggestions that make the community a better and more useful resource for everyone. Please reply here or PM me directly if you have any suggestions, concerns, or bugs to report.

We're constantly trying to improve to build a better community for us all.

Thanks!
 

pjk

Administrator
Staff member
Joined
Mar 13, 2006
Messages
6,087
Likes
328
WCA
2007KELL02
YouTube
pjkcards
Thread starter #3
How about the youtube embeds, you know what's wrong with them?
These should be fixed as of today, apologies about the delay in resolving that. Are you still noticing any issues? If so, please post the link. Thanks.
 
Joined
Dec 24, 2015
Messages
1,270
Likes
689
#4
(Not sure if this counts as an actual issue.) Disabling italics inside code tags would be pretty nice, because sometimes I have code that's iterating over an array (as in array[i]), and that gets mangled by the BBCode parser.
 
Joined
Dec 24, 2015
Messages
1,270
Likes
689
#5
Thread merging happens very often on this forum, but oftentimes a thread's title contains information not in the post body, and when the thread gets merged into a bigger thread, that information is lost. Unless the original thread title is completely uninformative (e.g. stuff like "help?????"), it would be a good idea to include the original thread title in the moved post.
 

pjk

Administrator
Staff member
Joined
Mar 13, 2006
Messages
6,087
Likes
328
WCA
2007KELL02
YouTube
pjkcards
Thread starter #6
Thread merging happens very often on this forum, but oftentimes a thread's title contains information not in the post body, and when the thread gets merged into a bigger thread, that information is lost. Unless the original thread title is completely uninformative (e.g. stuff like "help?????"), it would be a good idea to include the original thread title in the moved post.
Noted and will discuss this further with other moderators. Thanks.
 
Joined
Feb 18, 2018
Messages
1,749
Likes
633
WCA
2016STEE01
#7
I do not know if someone has mentioned this or not but I was trying to look at the Forum Rules and ever time I press it it says Error 404... Is there anything that I can do to fix that on my end? or is it just site related? Thank you very much in advance for your help.
 

pjk

Administrator
Staff member
Joined
Mar 13, 2006
Messages
6,087
Likes
328
WCA
2007KELL02
YouTube
pjkcards
Thread starter #8
I do not know if someone has mentioned this or not but I was trying to look at the Forum Rules and ever time I press it it says Error 404... Is there anything that I can do to fix that on my end? or is it just site related? Thank you very much in advance for your help.
Fixed, thanks for reporting this.
 
Joined
Jul 26, 2018
Messages
4
Likes
1
#10
I'm not sure if this is a problem of my own, but every time I try to change my avatar, the browser crashes immediately after I clicked on the "choose file". I tried Chrome, Firefox, and Edge, all the same. Thanks!

Edit:
Well, it worked when I switched to Linux from Windows, might be something wrong with the Windows?
 
Last edited by a moderator:
Joined
Dec 24, 2015
Messages
1,270
Likes
689
#11
the browser crashes immediately
Well, it worked when I switched to Linux from Windows, might be something wrong with the Windows?
This is very definitely a problem with your computer and not the website. Random stab in the dark: maybe you have a hard drive failure of some sort and it's causing the file picker to crash.
 

pjk

Administrator
Staff member
Joined
Mar 13, 2006
Messages
6,087
Likes
328
WCA
2007KELL02
YouTube
pjkcards
Thread starter #12
I'm not sure if this is a problem of my own, but every time I try to change my avatar, the browser crashes immediately after I clicked on the "choose file". I tried Chrome, Firefox, and Edge, all the same. Thanks!
Have you tried to reboot your computer and try again? I can't replicate the issue and haven't had any others mention this issue.
 
Joined
Jul 26, 2018
Messages
4
Likes
1
#13
Have you tried to reboot your computer and try again? I can't replicate the issue and haven't had any others mention this issue.
Sorry for the delay, I did some research and found it's actually a bug with the Windows File Explorer that's causing the crash, thanks!
 
Joined
May 4, 2011
Messages
484
Likes
70
Location
Madrid, Spain, Spain
WCA
2010BENI02
YouTube
naker115
#14
i searched "cut between corners and edges mbld" and it lead me to page 69 (gigiddy) of the mbld discussion thread, but when i clicked (left click, not wheel click or anything) it showed me as if logged out
I tried to replicate it searching this thread and everything was fine, the only difference i can come up with is that this is the last page of a thread, and the first
clicking log in again from the thread not only would be anoying but it didnt work, nor refreshing
 
Joined
Dec 24, 2015
Messages
1,270
Likes
689
#15
i searched "cut between corners and edges mbld" and it lead me to page 69 (gigiddy) of the mbld discussion thread, but when i clicked (left click, not wheel click or anything) it showed me as if logged out
Might be due to the search engine returning the HTTP link to the site rather than HTTPS, and you're only logged in to the HTTPS site. I see this with some of the links from some wiki pages too.

Maybe it's time to start doing automatic HTTPS redirects?
 

pjk

Administrator
Staff member
Joined
Mar 13, 2006
Messages
6,087
Likes
328
WCA
2007KELL02
YouTube
pjkcards
Thread starter #16
i searched "cut between corners and edges mbld" and it lead me to page 69 (gigiddy) of the mbld discussion thread, but when i clicked (left click, not wheel click or anything) it showed me as if logged out
I tried to replicate it searching this thread and everything was fine, the only difference i can come up with is that this is the last page of a thread, and the first
clicking log in again from the thread not only would be anoying but it didnt work, nor refreshing
Are you using the Xenforo search engine or the Google search engine?

Might be due to the search engine returning the HTTP link to the site rather than HTTPS, and you're only logged in to the HTTPS site. I see this with some of the links from some wiki pages too.

Maybe it's time to start doing automatic HTTPS redirects?
This would be an issue. When do you see this issue happening so I can replicate?
 
Joined
Dec 24, 2015
Messages
1,270
Likes
689
#17
This would be an issue. When do you see this issue happening so I can replicate?
I thought I'd seen it happen somewhat recently, but I can't reproduce it either. (It looks like the "old" URLs for the old forum software already automatically redirect to HTTPS, and the vast majority of the newer links are already HTTPS.)
 

pjk

Administrator
Staff member
Joined
Mar 13, 2006
Messages
6,087
Likes
328
WCA
2007KELL02
YouTube
pjkcards
Thread starter #19
the google one, only now i've noticed there is a site search tab
Soon I will be replacing the search with Elasticsearch which should provide much much better results.

In terms of it logging you out, has this issue always happened or did it just start? Does it happen in all browsers?
 
Joined
Feb 18, 2018
Messages
1,749
Likes
633
WCA
2016STEE01
#20
Hey @pjk, I just wanted to point out that (a) the search engine is not working at the moment, and (b) when you press on a members profile, and click on the "Posting" button it comes up with the same error code as that with the search engine. The error code is
"Oops! We ran into some problems.
A server error occurred. Please try again later."​
Thanks in advance for checking on it, and (since I believe in you to fix it) thanks for fixing it : )
 
Top