Issue Connecting to Speedsolving

Discussion in 'Help, support & suggestions' started by Ross The Boss, Aug 11, 2015.

Welcome to the Speedsolving.com. You are currently viewing our boards as a guest which gives you limited access to join discussions and access our other features. By joining our free community of over 30,000 people, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact us and we'll help you get started. We look forward to seeing you on the forums!

Already a member? Login to stop seeing this message.
  1. Ross The Boss

    Ross The Boss Member

    970
    2
    Jun 9, 2012
    Ontario Canada
    WCA:
    2012SVEN01
    YouTube:
    RossTheBossCubing
    Hi, I'm making this thread on behalf of another user who is having issues accessing speedsolving.com from his home. The browser he uses is Firefox 39, and his operating system is Windows XP if that is at all relevant. Upon attempting to access the forums, he is presented with this error message:

    "ERR_SSL_VERSION_OR_CIPHER_MISMATCH
    A secure connection cannot be established because this site uses an unsupported protocol."

    He has been having these issues for 'at least a week.'

    Thanks.
     
  2. pjk

    pjk Administrator Staff Member

    5,729
    106
    Mar 13, 2006
    Bangkok
    WCA:
    2007KELL02
    YouTube:
    pjkcards
    It's been happening for at least a week, was it working fine before then? Has he changed his browser or settings in the last week? The issue appears to be with the browser settings. To see if this is the case, have him try another browser. So far, no other users have mentioned this issue.
     
  3. ramba

    ramba Member

    2
    0
    Apr 2, 2016
    "ERR_SSL_VERSION_OR_CIPHER_MISMATCH
    A secure connection cannot be established because this site uses an unsupported protocol."
    give me the solution?
     
  4. ramba

    ramba Member

    2
    0
    Apr 2, 2016
    Here’s the main I got for my problem,


    Let me to answer to your questions:

    1. Q:Is this issue specific to some websites? Which websites are you trying to open?

    A:Yes, it is specific to the bank's site - TD bank. When I try to open the site to my private account info I

    receive the above message. The site could be open without problems with Firefox browser but

    COULD'T with IE11 and Google Chrome. I suspect that the latter take the info about root certificates

    from the IE11.


    · 2. Q:What exactly happens when you try to open a website in Internet Explorer?

    · A: I receive the message "“ERR_SSL_VERSION_OR_CIPHER_MISMATCH” or in some cases "the site

    · couldn't be open, please check your connection" but I know that the connection is good.

    · 3. Q: When exactly do you receive the error, “ERR_SSL_VERSION_OR_CIPHER_MISMATCH”?

    · A: I receive the above message when I've inserted my User Name and password and go next trying to

    · get access to my private information through the banking site as I have been doing it before the

    · problem.

    · What would you suggest me else?

    Try this - http://www.deskdecode.com/err_ssl_version_or_cipher_mismatch/
     
    Last edited: Oct 15, 2016
  5. pjk

    pjk Administrator Staff Member

    5,729
    106
    Mar 13, 2006
    Bangkok
    WCA:
    2007KELL02
    YouTube:
    pjkcards

Share This Page